Home > Artikel > ERR_SSL_VERSION_OR_ CIPHER_MISMATCH

ERR_SSL_VERSION_OR_ CIPHER_MISMATCH

Was bedeutet ERR_SSL_VERSION_OR_CIPHER_MISMATCH ?

Das Problem ist, dass die SSL Verschlüsselung entweder noch mit SSL v3 (gilt als unsicher) oder mit einen CIPHER, der ebenfalls auf Grund von Sicherheitsbedenken nicht mehr zur Verfügung steht, genutzt wird.

In den meisten Fällen liegt es daran, dass aktuelle Browser SSL v3 nicht mehr unterstützen, sondern auf TLS bestehen. Wenn dies durch den HTTPS Server nicht angeboten wird, gibt es ein Problem.

Welche Browser sind betroffen

Alle gängen Browser haben inzwischen den Support für SSL v3 deaktiviert, bei den meisten lässt sich dieser auch nicht mehr einschalten.

Beispielsweise kann man bei Firefox bis zur Version 23 noch eine Verbindung aufbauen, ab Firefox 24 geht es nicht mehr.

Was kann man als Workaround machen?

Suchen Sie einen (virtuellen) PC auf dem Sie beispielsweise die Firefox Version 23 installieren und das Update (bei Windows ein Service) deaktivieren. Diese Möglichkeit haben Sie auch bei anderen Browser Herstellern.

Weiterführende Informationen seitens Mozilla

In diesem Knowledge Artikel bei Mozilla wird das Thema genau beschrieben - inkl. mit welchen Einstellungen man SSL v3 bis Firefox 23 wieder aktivieren kann.

Wo findet man Firefox 23 als Download?

Mozilla Download Archive

Portable Firefox Version 23 Download

Portable Firefox hat den Vorteil, dass man diese nicht installieren muss - und es somit auch keine Updates gibt.